python3下安装aiohttp遇到过的那些坑

阅读量:     Authors: Lemon PYTHONLIBRARIES
aiohttp

本文首发于我的微信公众号(ID:PyDataRoad)。

最近需要用到aiohttp这个库,在安装过程中遇到很多坑。google、baidu后,依然没有找到合适的解决方案。

后来通过去python官方的PyPI查看aiohttp库,才发现一些问题,几经折腾,最后终于成功的在python3下安装’aiohttp’。

在这里跟大家分享一下被坑的过程。

先说一下环境。 win7,64位。 电脑里安装的python有3.5和3.6两个版本。

1. python3.6下安装aiohttp

python3.6环境下,已将pip设置为pip36,类似的python3.5中的pip设置为pip35。

pip36 install aiohttp

运行结果如下:

pip36_aiohttp.png

google、百度查询“Command ‘python setup.py egg_info’ failed with error code 1 …” , 参考某些解决方法包括:

使用pip 安装python package出现的错误: “Command ”python setup.py egg_info“ failed with error code 1” 这个错误很可能是 setuptools安装出现问题。 解决: 第一步:检查pip安装的是不是正确 https://pip.pypa.io/en/stable/installing/ 第二步:如果pip已经安装: pip install –upgrade setuptools 第三步:如果已经更新了,测试下ez_setup是不是正常安装了,如果没有: pip install ez_setup 最后,再尝试: pip install unroll 再去 pip 安装自己需要的package。

以及stackflow和其他各种方法,依然没能解决问题。

2. python3.5下安装aiohttp

然后,转向python3.5,期待在python3.5下能顺利地安装,然而,出现的问题跟python3.6版本一样。着实让人费解与恼火。

然后,折腾了好久后,去查看aiohttp的官方说明文档,安装指南如下:

Library Installation

$ pip install aiohttp

You may want to install optional cchardet library as faster replacement for chardet:

$ pip install cchardet

For speeding up DNS resolving by client API you may install aiodns as well. This option is highly recommended:

$ pip install aiodns

由于说明文档里提到其他环境依赖库是“may”,我以为不是必须的,也没在意。不得不说,这个’may’确实会产生误导。 后来,实在不行,在python36下也进行安装 ‘cchardet’和’aiodns’

结果在安装’aiodns’时,也出现了类似的错误“Command ‘python setup.py egg_info’ failed with error code 1 …”。

3. aiohttp的不同版本

最后,去python官网的PyPI中去查看,看看有没有供参考的内容。 PyPI中搜索’aiohttp’,第一个出来的 ‘aiohttp 2.0.7’,就是要找的 aiohttp安装库。 打开’aiohttp 2.0.7’,查看安装库的whl文件,界面如下:

aiohttp_whl.png

通过观察,发现aiohttp库2.0.7版在windows系统下,没有python3.5和python3.6的安装包。而通过pip安装时,如果不指定版本号,默认安装的是最新的版本,即’aiohttp 2.0.7’。

所以,要想在python3.5或python3.6环境下安装windows系统下的’aiohttp’库,可能需要安装’aiohttp’的其他版本。 经过一番研究,发现可以安装’aiohttp’1.3.3版本。

在PyPI中找到’aiohttp’1.3.3版本,查看其whl安装文件,如下: aiohttp1-3-3_whl.png

发现’aiohttp’1.3.3版本是有windows系统下可安装的python36和python35版本的。于是:

pip36 install aiohttp==1.3.3

也出现类似的问题“Command ‘python setup.py egg_info’ failed with error code 1 …”。 至此,这个问题在安装不同package的时候都出现,后来将想,是不是安装包依赖的其他库的安装环境也存在某些系统或python版本下不存在可供安装的安装包(或whl文件)。于是,先查看’aiohttp 1.3.3’的安装依赖库,如下:

Requires Distributions

yarl (<0.10,>=0.9.8)

multidict (>=2.1.4)

chardet

async-timeout (>=1.1.0)

请注意’yarl’的版本需求,’yarl’目前最新的版本是0.10.1版,如果pip安装时不指定版本的话,默认安装的是’yarl’0.10.1版,这样也会导致安装失败,所以需要进行指定版本安装,如下:

pip36 install yarl==0.9.8

pip35 install yarl==0.9.8

如果你的pip没有进行过重新设置,则:

pip install yarl==0.9.8

但是,上述安装命令同样会产生类似的错误:“Command ‘python setup.py egg_info’ failed with error code 1 …”。这是因为,安装’yarl==0.9.8’需要先安装multidict库。 于是,在PyPI中查看’multidict’的whl文件,发现这个库目前没有python3.6下可以安装的安装包。所以,只能安装’multidict’在python3.5下的安装包。继而,’yarl==0.9.8’以及’aiohttp==1.3.3’也只能安装python3.5的版本。而’chardet’,通过PyPI查看可知,没有指定python的版本,直接pip安装的就可以。

因此,在python3.5下,windows系统中最后成功安装’aiohttp==1.3.3’的步骤如下:

  1. pip35 install multidict
  2. pip35 install chardet
  3. pip35 install yarl==0.9.8
  4. pip35 install aiohttp==1.3.3

4. 总结

在python下安装第三方库的时候,可以需要其他依赖库,在安装过程中,如果遇到如下类似的问题:

“Command ‘python setup.py egg_info’ failed with error code 1 …”。

则可能是环境依赖库的问题,可以去PyPI中查看第三库安装时所依赖的安装环境,这样,或许能一步步解决第三方库安装时遇到的问题。通过上述描述,希望大家能在后续安装时避免这些坑。


对我的文章感兴趣的朋友,可以关注我的微信公众号(ID:PyDataRoad),接收我的更新通知。

« Previous Next »